1958 Jaguar XK150 Fixed Head Coupé RHD - S824294DN
Maintenance

Page list

When I bought my XK150 in 2013 for an amount close to the asking price, I was confident that the agreed price was fair value. It had taken me two years to find an XK150 FHC that had matching numbers, and was either in original condition, unrestored, or fully restored (off-chassis) with photos and documents to prove it. The restored car I decided to buy had bodywork, and interior and exterior trim, which was first class. Mechanically, the car was sound and, fortunately for me, the more I drove the car after purchase, the more the excellent underlying mechanical condition was reinforced.

However, as time passed and I got to know the car better, it turned out that the car had one major fault in the gearbox (jamming in first gear), and quite a few relatively minor faults - things that take time to fix, but do not cost a lot of money if undertaken by the owner. Some of these faults were hard to detect when initially inspecting the car, and when the car is initially driven. In hindsight, even if I had found many of these faults before purchasing, I doubt any of them would have stopped me buying the car, because in an overall sense the car was fundamentally sound and beautifully presented.

I also reflected later that there had been a period of 14 years since the restoration had been completed when I bought the car. Some of the faults were time-related.

The gearbox jamming in first gear was a fault that did not show up until I had owned and driven the car over a period of more than a month. The jamming in first gear occurred only occasionally. Even though this was the fourth Jaguar I had owned with the classic Moss gearbox (previously 1951 Mk V, 1954 Mk VIIM, 1949 3-1/2 saloon), I was unaware of the first gear jamming problem. I later found that the jamming event would occur in my car only under certain conditions, and to this day I am not aware if the fault was or is present in other than in the XK models. See Moss box rebuild.

Below is a record of the repairs made to my car in the first year or so of ownership.

Page list

Carb needles not seating after car not used for several weeks

 

 

 

 

 

 

The brass float operating lever in each carburettors had been wrongly adjusted, meaning the float was unable to rise when fuel reached the bowl, after the float bowl fuel level dropped markedly after a long period of non-use, especially in summer.

Referring to the diagram, in each carb, the lever was bent downwards along the red line, and then upwards along the green line. There should be no bend at the red line - the metal should be flat on the right side of the green line. To adjust the float level, bend the metal up or down only to the left of the green line.



carbfloatlever

Click to view

Carb fuel union banjo joints not tight

 

 

This fault showed up during the first long trip of several hundred kilometres. Everything had reached full operating temperature in the engine compartment, and under hours of sustained pressure from the fuel pump, the seventeen year old fibre washers must have softened (?), and a small amount of fuel started to leak, causing a smell in the cabin. The banjo bolts each needed about 1/3 turn to tighten. I had checked these connections in the first week of ownership. Maybe I should have re-checked these two connections earlier in my ownership period.
Spark timing not correct The car always started easily enough, but the timing was out - 1 degree BTDC.  Usually not hard to correct, but ...
Advance-retard adjustment knob seized ... the advance-retard screw adjuster was seized. This problem was fixed during a full rebuild of the distributor mid-2016. The adjuster seizing had been caused by a liberal coating of a sticky product from what appeared to be a failure of the upper radiator hose long ago. A new vacuum advance unit was fitted because the linkage from the vacuum diaphragm had worn and had become sloppy to an unacceptable extent.
Infrequent intermittent spark plug dropping out The fault was a cracked insulator on one spark plug. The entire set of six was replaced.

Page list

Vacuum style windscreen washer not working

 

I finally got around to seeing if the vacuum-powered windscreen washer system worked. It did not. The rubber diaphragm in the pump had perished. I found a man in England who had made a male-female mould and had produced new diaphragms using silicon sealant. I installed the new diaphragm in the copper vacuum chamber, and held the two halves together with eight 3mm stainless metal threads, using a silicon sealant. The brass gauze on the suction pipe was damaged, so it was replaced with a section of a synthetic Paris almonds bag.
 
This is how a rubber component looks after being in an XK engine compartment for 100,000 miles
washer-bottle-pump-diaphragm-tn
Re-assembled pump
washer-pump-assembly-tn

Brake booster issuing a strange whoosh sound when brake pedal first depressed

 

This one was initially a mystery. In the moment when the brake pedal was first pressed, a whoosh sound could be heard from the left side of the engine compartment. It turned out that the air valve on the Girling booster had been incorrectly assembled, and was not opening quickly enough. In the air valve chamber, there is a conical helical spring. The largest end needs to sit flat in the chamber recess, but the very end of the wire was looped over the next turn of the spring, meaning that the air valve opening operation was not smooth. Adjusting (slightly bending) the very end of the last coil of the spring so it could not become tangled with the next coil fixed the problem, and the whoosh sound disappeared.

Eventually, I replaced the Girling piston-type booster with a PBR VH-40 diaphragm booster hidden from sight in the normal booster compartment.
 
Before
spring-was

After
spring-fixed

Page list

Tyres had hardened beyond safe levels

The five Dunlop cross-ply tyres on the car were purchased in 1999. The tyres were hard and unsafe. Bits of tread on the outer edge of the front tyres were broken off in places. The tyres were replaced within the first month of ownership with new Pirelli Cinturato 185VR16.

Some cooling system hoses in poor condition, one chafed against head The cooling and heater hoses were examined to see if they had suffered the same fate as the tyres. To some extent, the answer was yes. All but one cooling hose were hard-ish and were replaced. One hose was labelled 2012, and left in place. One of the two hoses between the firewall and engine had chafed against the head - fabric was showing. A short 50mm length of black thin wall plastic pipe slit lengthwise was used as a shroud (virtually invisible) on the new hose to prevent a recurrence.
Steering toe-in incorrect In conjunction with fitting the new tyres, the toe-in was checked. The setting was 0.5mm toe-out. That was corrected to 2mm toe-in.
Fuel gauge permanently read 3/4 full, whatever the fuel level in the tank This one had to be solved promptly. The main fault was that the fuel sender was faulty, but not open-circuited. A new Smiths sender was installed, and later calibrated (arm bent) to suit the XK150 tank shape.

But even with a new sender, the gauge did not indicate the tank's fuel content correctly. Long story - see here.
Low fuel light not functioning, even when sender fault fixed The low fuel light assembly within the gauge housing was incorrect, and the red light did not come on when low on fuel. The fix was time (lots of it), as anything involving work behind the XK150 dash is a pain. The light was not properly earthed.

Fuel pump inlet valve installed upside down

 

 

 

The first time I needed the fuel pump to suck fuel from the tank when the fuel pump did not have a flooded inlet, nothing happened. On dismantling the pump, the cause was obvious. The inlet valve, which is a ~2cm diameter brass disc slightly cupped at its rim, had been installed upside down. When installed properly, cupped side up, a conical helical spring above the inlet valve disc not only presses the disc to the closed position, but it is also the centering mechanism for the disc. With the disc upside-down, the disc could wander laterally, and that's exactly what it did, meaning it did not seat properly and the valve did not act effectively as a check valve. The disc was inverted and ground smooth, the valve seat ground flat, and the pump would then suck from the tank without first manually flooding the inlet.

Page list

Fuel smell in boot

 

 

On opening the boot, there was always a fuel smell. Inspection of the hose between the filler point and the tank indicated that it was probably the original concertina hose, although it could have been renewed during the 1998-99 restoration. Either way, the hose was very hard, although there was no sign of a fault. Notwithstanding, a new non-concertina hose has been fitted (fortunately hidden by its shroud) and the smell in the boot appears to have been eliminated.
Voltage regulator voltage set too high This fault was detected only after the clock was modified with the fitting of modern electronics. Over-voltage caused the clock to occasionally stop when the car was operating, and at another time, caused two dash panel lamps to blow. The problem was eventually traced to the voltage regulator set to 17 volts(!). That was adjusted to 15 volts. No more problems.

Heater fan not working, horn stopped working

 

The ground cable from the heater had become disconnected at some time shortly after purchase. Possibly I had dislodged a poor connection working under the dash on something else. I made sure the cable was firmly screwed to the dash steelwork. Later, the horn stopped working. I had to improve the attachment of the ground cable on the steering column to the dash steel work.
Speedo needle oscillated at higher speeds At higher speeds, 50+ MPH, the speedo needle began wavering. Reason: outer speedo cable part separated in two places, allowing excessive kinking. An entire new cable was fitted.

Overdrive throttle switch

 

The overdrive throttle-closed switch was not working. The switch was correctly adjusted, but the not making contact correctly. This fault was years of contact corrosion, and was solved by dismantling the switch, cleaning the contacts, and re-assembling the switch.

Oil filter sealing ring

 

This one was hard to solve. During a routine oil change soon after purchasing the car, I found I could not get the oil filter cannister to seal against traditional rectangular section oil sealing ring in the (unmachined) alloy housing groove. I had never had this problem in the past with the same style of Tecalemit oil filter housing. The solution was to switch to a Viton O-ring - instant success.

Page list

Passenger seat not sliding fore and aft properly The first time the passenger seat had to be adjusted, it would not move freely. Fixing involved removing the seat, and the runners being dismantled, because one runner had been bent by being unevenly-tightened against the (soft) carpet and sound-proofing, leaving the runner bent with a slight curve.)

Rear springs had sagged

 

I should have picked this fault earlier, but did not. The first time the car was parked near another XK150, it became clear that my car was low at the back end by at least 40mm. After much research, and considering have the existing springs reset, I opted for the more reliable long-term solution and bought a pair of new springs. Problem solved. See here for dimensional details of the new and old rear springs.
Leaking filter housing to sump oil return hose Either this hose was not replaced in 1998-99, or had degraded due to being the wrong type of rubber. The design of this oil bypass return connection to the sump is primitive, and demands a hose that is in perfect condition, which the hose on my car when bought, was not. Solution: a new 220mm long oil and fuel resistant 16mm steel braided hose bought from a nearby hydraulics service shop.
Wipers do not automatically park correctly This one was not fixed until nearly three years after I bought the car. I found the cause, and fixed the problem mid-2016. The time required to remove and refit the wiper motor is considerable. Until I got around to the task, the wipers had to be parked properly by turning them off at the right time. Another long story! See DR3 wiper motor repair here
Driver's door not closing properly The driver's door had "dropped" by about 3mm at the rear edge, and would not close properly without undue slamming. A shim of 1mm thick galavanised steel sheet 65mm square with four 8mm slotted holes at 51mm centres, then cut in half down the centre, and inserted in the lower hinge attachment to the door lifted the rear edge of the door 2.7mm - problem solved - click! Cost: 80 cents plus time.

... and this one!

 

 

One morning, I opened thar driver's door to see a black rubber cap and a spring on the driver's seat. How did that get there? What is it? Ah, it's the dip switch rubber cap and the spring from inside the switch.
The metal cap of the switch is held on by a rivetted connection. Over 57 years of headlight dipping cycles, the rivet mechanical strength had been affected by a form of fatigue, and one day the rivet had let go. Solution: new Lucas switch from UK. Later I was able to work out a solution to repair the original switch, now held as a spare.